Inhaltsverzeichnis
Importieren von neuen Benutzern / einer aktualisierten Benutzerliste
Aus dem Schul-Netz auf http://bibserv.intern/library/login zugreifen.
Login mit den in den itzks-creds der jeweiligen Schule hinterlegten Zugangsdaten.
Vor Änderungen via Backup > komplettes Backup erstellen eine Sicherung des aktuellen Datenbankstandes anlegen.
Importieren von neuen / aktualisierten Benutzern via Im-/Export > Personendaten importieren > Durchsuchen und die gewünschte Quelldatei (.csv mit den vorhandenen Daten Nachname, Vorname, Geburtsdatum, Klasse) wählen. Dann den Anweisungen folgen u. entsprechende Auswahlen treffen.
Zugriff auf Schullogistik via Browser
Aus dem Schul-Netz auf bibserv.intern/schul-logistik oder bibserv.intern:3000 zugreifen.
Login mit den korrekten Zugangsdaten.
Schul-Logistik nicht erreichbar / funktionsfähig
LSB: Library kann nicht gestartet werden
Beispieloutput im Terminal:
$ sudo systemctl status schul-logistik-library.service
● schul-logistik-library.service - LSB: Library
Loaded: loaded (/etc/init.d/schul-logistik-library; generated; vendor
preset: enabled)
Active: failed (Result: exit-code) since Tue 2019-01-22 12:07:09 CET; 2min
18s ago
Docs: man:systemd-sysv-generator(8)
Process: 4566 ExecStart=/etc/init.d/schul-logistik-library start
(code=exited, status=127)
Jan 22 12:07:08 bibserv.intern systemd[1]: Starting LSB: Library...
Jan 22 12:07:08 bibserv.intern schul-logistik-library[4566]: Starting
schul-logistik-library
Jan 22 12:07:08 bibserv.intern su[4568]: Successful su for www-rails by root
Jan 22 12:07:08 bibserv.intern su[4568]: + ??? root:www-rails
Jan 22 12:07:08 bibserv.intern su[4568]: pam_unix(su:session): session opened
for user www-rails by (uid=0)
Jan 22 12:07:09 bibserv.intern systemd[1]: schul-logistik-library.service:
Control process exited, code=exited status=127
Jan 22 12:07:09 bibserv.intern systemd[1]: Failed to start LSB: Library.
Jan 22 12:07:09 bibserv.intern systemd[1]: schul-logistik-library.service:
Unit entered failed state.
Jan 22 12:07:09 bibserv.intern systemd[1]: schul-logistik-library.service:
Failed with result 'exit-code'.Dies kann am thin.service liegen:
$ sudo systemctl status thin
● thin.service - LSB: thin initscript
Loaded: loaded (/etc/init.d/thin; generated; vendor preset: enabled)
Active: active (exited) since Sun 2018-11-11 08:24:44 CET; 2 months 11 days ago
Docs: man:systemd-sysv-generator(8)
Tasks: 0 (limit: 4915)
CGroup: /system.slice/thin.serviceHier dann via
sudo systemctl stop thin sudo systemctl start thin
den thin.service neu starten.
Danach ist
$ sudo systemctl status thin
● thin.service - LSB: thin initscript
Loaded: loaded (/etc/init.d/thin; generated; vendor preset: enabled)
Active: active (exited) since Tue 2019-01-22 15:51:53 CET; 12min ago
Docs: man:systemd-sysv-generator(8)
Process: 10119 ExecStop=/etc/init.d/thin stop (code=exited, status=0/SUCCESS)
Process: 10366 ExecStart=/etc/init.d/thin start (code=exited, status=0/SUCCESS)
Tasks: 0 (limit: 4915)
CGroup: /system.slice/thin.service
Jan 22 15:51:50 bibserv.intern systemd[1]: Starting LSB: thin initscript...
Jan 22 15:51:50 bibserv.intern su[10368]: Successful su for www-rails by root
Jan 22 15:51:50 bibserv.intern su[10368]: + ??? root:www-rails
Jan 22 15:51:50 bibserv.intern su[10368]: pam_unix(su:session): session opened for user www-rails by (uid=0)
Jan 22 15:51:51 bibserv.intern thin[10366]: Using /var/lib/www-rails/.rvm/gems/ruby-2.2.2
Jan 22 15:51:52 bibserv.intern thin[10366]: Starting server on 0.0.0.0:3000 ...
Jan 22 15:51:53 bibserv.intern systemd[1]: Started LSB: thin initscript.wieder funktionsfähig.
Zugriff vom TJENER.<SCHULE> auf Schul-Logistik unter bibserv.intern:3000/login prüfen.
