Inhaltsverzeichnis
Probleme bei der Benutzeranmeldung
Es gibt mehrere Ursachen für fehlschlagende Anmeldungen:
Ursache 1: $HOME/.dmrc verhindert die Anmeldung
Die Datei $HOME/.dmrc enthält einen Wert (z.Bsp. fail-safe), der den Login-Manager dazu verleitet, nicht in den Desktop hineinzustarten. Leider ist der Anmeldefehler recht stumm, man landet wieder beim Anmeldedialog.
Lösung: Die Datei $HOME/.dmrc des entsprechenden Benutzers löschen.
$ sudo rm /skole/tjener/home<1 oder 2>/<UID>/.dmrc
Ursache 2: Der Kerberos Principal (der Kerberos Account des Nutzers) ist gesperrt
Lösung:
Hier ist zunächst zu prüfen, ob das Problem wirklich der Kerberos Account ist.
Beispiel der Vorgehensweise:
<admin>@tjener:~$ sudo -i
root@tjener:~# kadmin.local
Authenticating as principal <admin>/admin@INTERN with password.
kadmin.local: getprinc <UID>
Principal: <UID>@INTERN
Expiration date: [never]
Last password change: Do Feb 16 11:50:29 CET 2017
Password expiration date: [none]
Maximum ticket life: 0 days 10:00:00
Maximum renewable life: 7 days 00:00:00
Last modified: Do Feb 16 11:50:29 CET 2017 (root/admin@INTERN)
Last successful authentication: [never]
Last failed authentication: [never]
Failed password attempts: 0
Number of keys: 8
Key: vno 7, aes256-cts-hmac-sha1-96, no salt
Key: vno 7, arcfour-hmac, no salt
Key: vno 7, des3-cbc-sha1, no salt
Key: vno 7, des-cbc-crc, no salt
Key: vno 7, des-cbc-md5, no salt
Key: vno 7, des-cbc-md5, Version 5 - No Realm
Key: vno 7, des-cbc-md5, Version 5 - Realm Only
Key: vno 7, des-cbc-md5, AFS version 3
MKey: vno 1
vvvvvvvvvvvvvvvv
Attributes: DISALLOW_ALL_TIX REQUIRES_PRE_AUTH
^^^^^^^^^^^^^^^^
Policy: users
kadmin.local:Wenn DISALLOW_ALL_TIX geflaggt ist, dann muss man dies rückgängig machen:
root@tjener:~# kadmin.local -q "modify_principal +allow_tix <UID>"
Als Ausgabe kommt dann:
Authenticating as principal <admin>/admin@INTERN with password. Principal "<UID>@INTERN" modified.
